failed install on DNN 7.0.2

Jan 31, 2013 at 4:04 AM
Hello I just tried to install this cool looking module on a new install of DNN 7 running in Windows Azure. The install of DNN is using Azure SQL not table storage.

Here is the error -

SQL Execution resulted in following Exceptions: System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'sysindexes'. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async, Int32 timeout) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at DotNetNuke.Data.SqlDataProvider.ExecuteScriptInternal(String connectionString, String script) ClientConnectionId:a1a9dbae-8422-4ed8-965c-a691d94196d6 /* INSTALL SQL PROVIDER SCRIPT Injection Module for DotNetNuke Version: 1.00.02 Author: Will Strohl E-Mail: will.strohl@gmail.com Website: http://www.willstrohl.com Copyright 2009 Will Strohl Release Notes: This update patches SQL problems that were created. */ IF EXISTS(SELECT 1 FROM [sysindexes] WHERE [name] = N'IX_wns_inj_injection_injectcontent') BEGIN DROP INDEX [IX_wns_inj_injection_injectcontent] ON dbo.[wns_inj_injection] END

Thank you for your work on this module!!
Jan 7, 2014 at 2:28 AM
I received the same error when trying to install the module in Azure on version 7.1.2
Jun 9, 2014 at 7:15 PM
Same for me, will not install on DNN with sql azure. I used 7.2.2
Jun 20, 2014 at 5:52 PM
Hey everyone:

I am sorry that this did not install for you. I'll try to look at it as soon as I can. In the meantime, if any of you are developers, feel free to create a pull request if you find time to fix it. I have this and my other modules on Github for source control now. I am only using Codeplex for distribution & support. :)
Jun 20, 2014 at 6:27 PM
Edited Jun 20, 2014 at 6:27 PM
One more note... I just installed and tested on 7.2.1 and 7.3.0 just fine, but not on Azure. Fixing for Azure is generally pretty simple.